Trụ sở tại Hà Nội

Số 2A/125 Bùi Xương Trạch – Thanh Xuân – Hà Nội

090 605 1599 - 096 350 6565

kinhdoanh@cnttshop.vn

07h30 đến 17h30

Hướng dẫn cấu hình Firewall Cisco ASA mode Transparent

Bài viết này sẽ giúp các bạn hiểu Chế độ Transparent trong Tường lửa cisco ASA và cách cấu hình Firewall Cisco ASA. Hướng dẫn này áp dụng với các thiết bị tường lửa Cisco ASA5506 ASA5510 ASA5512 ASA5515 ASA5520 ASA5525 ASA5540 ASA5545 ASA5550 ASA5555 ASA5580...

Lợi ích của mode Transparent

  • Không thay đổi dải địa chỉ IP, mô hình mạng hiện tại
  • Các giao thức định tuyến có thể đi qua firewall
  • Các giao thức HSRP, VRRP, GLBP... có thể đi qua Firewall
  • Các traffic Non-IP như IPX, MPLS, BPDUs... được cho phép qua firewall
  • Multicast streams có thể đi qua Firewall

Đặc điểm chính của Mode Transparent

  • Chế độ tường lửa transparent chỉ hỗ trợ hai giao diện (inside và outside)
  • Tường lửa kết nối các gói từ Vlan này sang Vlan khác thay vì định tuyến chúng.
  • Tra cứu MAC được thực hiện thay vì tra cứu bảng định tuyến.
  • Có thể chạy một hoặc nhiều tường lửa.
  • Một địa chỉ IP quản lý được yêu cầu trên ASA.
  • Địa chỉ IP quản lý phải nằm trong cùng mạng con với mạng được kết nối.
  • Mỗi giao diện của ASA phải là một giao diện Vlan khác nhau.
  • Mặc dù thiết bị hoạt động như một cầu nối lớp 2, lưu lượng lớp 3 không thể đi qua firewall từ cấp độ bảo mật thấp hơn đến giao diện cấp độ bảo mật cao hơn.
  • Tường lửa có thể cho phép mọi lưu lượng truy cập thông qua bằng cách sử dụng Access List (ACL).

Các tính năng không được hỗ trợ trong mode Transparent

  • DHCP Relay - firewall transparent có thể hoạt động như một máy chủ DHCP, nhưng nó không hỗ trợ các lệnh chuyển tiếp DHCP.
  • Các giao thức định tuyến động sẽ không được phép, tuy nhiên có thể sử dụng các tuyến tĩnh cho lưu lượng truy cập bắt nguồn từ ASA
  • Định tuyến IP Multicast
  • QoS
  • VPN termination - firewall transparent hỗ trợ các đường hầm VPN tại chỗ chỉ dành cho các kết nối quản lý và không dành cho các kết nối không quản lý.

mô hình triển khai tường lửa firewall cisco asa mode transparentMô hình triển khai Firewall mode Transparent

Các bước cấu hình Cisco ASA mode Transparent

Bước 1: Chuyển Firewall sang mode Transparent

ciscoasa# conf t
ciscoasa(config)# firewall transparent

Bước 2: Gán các cổng vào các vlan

ciscoasa(config)# interface Ethernet 0/0
ciscoasa(config-if)# switchport access vlan 10
ciscoasa(config-if)# no shutdown
ciscoasa(config-if)# interface Ethernet 0/1
ciscoasa(config-if)# switchport access vlan 20
ciscoasa(config-if)# no shutdown

Bước 3: Cấu hình interface vlan và gán các vlan vào chung 1 bridge-group

ciscoasa(config-if)# interface vlan 10
ciscoasa(config-if)# nameif outside
INFO: Security level for “outside” set to 0 by default.
ciscoasa(config-if)# bridge-group 1
ciscoasa(config-if)# interface vlan 20
ciscoasa(config-if)# nameif inside
INFO: Security level for “inside” set to 100 by default.
ciscoasa(config-if)# bridge-group 1

Bước 4: Cấu hình IP management thông qua Bridge Virtual Interface (BVI)

ciscoasa(config-if)# interface bvi 1
ciscoasa(config-if)# ip address 192.168.0.10

Như vậy là chúng ta đã cấu hình xong Firewall Cisco ASA mode transparent. Các bước tiếp theo tùy thuộc vào mô hình mạng của từng công ty, chúng ta sẽ cấu hình các dịch vụ tương ứng.


Tin tức, Tin tức (Trang chủ), Cisco

Tin liên quan

  • Hướng dẫn kích hoạt giao diện Web Switch Cisco
  • Kiến trúc mạng SD-WAN của Cisco và các thành phần của SD-WAN
  • Hướng dẫn cấu hình Port Forwarding, NAT Port trên Fortigate
  • [Citrix ADC] Hướng dẫn cấu hình cân bằng tải trên Citrix ADC
  • [Citrix ADC] Hướng dẫn cấu hình cơ bản trên Citrix ADC
  • Hướng dẫn cấu hình Firewall Cisco ASA mode Transparent
  • FortiClient là gì? Các tính năng và mô hình hoạt động của FortiClient
  • vPC là gì? Hướng dẫn cấu hình vPC trên Switch Cisco Nexus
  • [CISCO] Hướng dẫn Reset Switch Cisco C9200, C9300 C9500 về cấu hình mặc định
  • [RUCKUS] Hướng dẫn Cấu hình nhiều Vlan trên SSID (Ruckus Unleashed)
  • SSH là gì? Hướng dẫn cấu hình SSH trên các thiết bị Cisco
  • Mesh Wifi là gì? Ưu nhược điểm của Mesh Wifi
  • SFP-DD Next Generation SFP Module to Support 100G
  • QSFP-DD Optical Form Factor: Bước tiến lớn tới kết nối 400GbE
  • [RUCKUS] Hướng dẫn cấu hình LACP trên Wifi Ruckus R710
  • [RUCKUS] Joint các AP Member vào Unleashed AP Master
  • [RUCKUS] Tùy chỉnh mạng LAN không dây ở chế độ Unleashed
  • [RUCKUS] Ruckus Unleashed là gì? Lợi ích khi triển khai Ruckus Unleashed
  • [RUCKUS] Hướng dẫn Cấu hình Wifi Ruckus chạy Unleashed Mode
  • [RUCKUS] Hướng dẫn Reset Ruckus ZoneDirector 1200
  • [RUCKUS] Hướng dẫn cấu hình cơ bản Ruckus ZoneDirector 1200
  • [RUCKUS] Hướng dẫn cấu hình Wifi Ruckus hoạt động ở chế độ Standalone
  • [UNIFI] Hướng dẫn cấu hình và cài đặt Unifi controller
  • [FortiOS 5.4] Cấu hình quản lý truy cập qua địa chỉ MAC trên Fotigate
  • [FortiOS 5.4] Hướng dẫn cấu hình Application control