Logo CNTTShop.vn

Hotline: 0862 323 559

Công Ty TNHH Công Nghệ Việt Thái Dương
NTT03, Line 1, Thống Nhất Complex, 82 Nguyễn Tuân, Thanh Xuân, Hà Nội.
Danh mục sản phẩm

Hướng dẫn cấu hình Cisco Catalyst 1200 và 1300 bằng CLI

 

Trong bài viết này, mình sẽ hướng dẫn các bạn cấu hình cơ bản Switch Cisco C1200, C1300 bằng giao diện dòng lệnh CLI như đăng nhập vào switch (tài khoản mặc định), tạo VLAN, tạo và phân quyền cho tài khoản, gán cổng vào VLAN, cấu hình Trunking trên switch, lưu cấu hình trên Cisco Catalyst 1200 và 1300 Series.

Dòng cisco C1200 C1300 hỗ trợ cấu hình bằng cả giao diện dòng lệnh và giao diện web. Với những bạn mới tiếp cận thì giao diện web sẽ đơn giản hơn để cấu hình, tuy nhiên sẽ mất nhiều thời gian hơn và khó khắc phục sự cố. Giao diện dòng lệnh thì cấu hình sẽ nhanh hơn rất nhiều, dễ xử lý sự cố, tuy nhiên thì nó yêu cầu các bạn cần có kỹ năng, hoặc đã học các khóa học như CCNA.

Nếu các bạn không quen sử dụng giao diện dòng lệnh, các bạn có thể tham khảo hướng dẫn cấu hình 2 dòng switch này trên giao diện web tại đây: Hướng dẫn cấu hình cơ bản switch Cisco Catalyst 1200, 1300 Series bằng giao diện web.

Đăng nhập vào switch

Để cấu hình bằng giao diện dòng lệnh, chúng ta sẽ có 2 cách để truy cập vào CLI của switch. Cách 1 là các bạn truy cập vào switch bằng giao diện web, sau đó bật TELNET, SSH và truy cập qua 2 giao thức này. Tuy nhiên nó yêu cầu có IP và các bạn phải hoàn tất các bước cài đặt ban đầu bằng giao diện web. Cách 2 là các bạn sử dụng dây console. Với dây console thì các bạn có thể theo dõi được cả khi switch đang khởi động, nên nó rất dễ để xử lý sự cố. 

Tất cả các mã switch thuộc dòng Cisco Catalyst 1200 và Catalyst 1300 đều có 2 cổng console chuẩn RJ45 và USB Type-C (trừ mã C1200-8T-D chỉ có cổng console RJ45).

các cổng console trên switch Cisco Catalyst 1200 và 1300

Các bạn sử dụng dây console để kết nối thiết bị với máy tính của mình. Có 3 loại dây console phổ biến, các bạn sử dụng loại nào cũng được. Ngoài ra thì có nhiều loại cable console khác, các bạn cũng có thể sử dụng để cấu hình switch.

các loại dây console phổ biến trên thị trường

Sau khi các bạn kết nối dây console với máy tính, trên máy tính sẽ nhận các dây console này như các cổng COM. Các bạn kích chuột phải vào This PC, chọn Manage. Trong Computer Management, truy cập vào Device Manager > Ports (COM & LPT). Trong mục Ports (COM & LPT), các bạn kiểm tra xem máy tính đang nhận cable Console là cổng COM nào, như ví dụ của mình là COM3.

Các bạn lưu ý máy tính sẽ có nhiều cổng COM khác nhau, nên các bạn cần tìm chính xác cổng COM của cable console. Nếu không xác định được thì các bạn có thể rút dây console ra và cắm lại, cổng COM nào mất khi các bạn rút ra chính là cổng COM của cable Console.

Ngoài ra có 1 vài trường hợp các bạn cần cài Driver cho dây console nếu windows không tự nhận. Các bạn xem hãng sản xuất của dây console và tìm driver tương ứng, hoặc sử dụng driver phổ biến như CH341SER hoặc PL23XX_Prolific_DriverInstaller.

kiểm tra máy tính nhận cổng COM nào

Sau khi xác định được cổng COM, các bạn sử dụng phần mềm terminal phổ biến như Putty, Tera Term, Moba Xterm, SecureCRT... để đăng nhập vào switch với các thông số (ví dụ sử dụng phần mềm Putty):

  • Serial Line: nhập cổng COM đã nhận trên máy tính.
  • Speed (baud rate): 115200
  • Data bits: 8
  • Stop bits: 1
  • Parity: None
  • Flow control: None

thiết lập thông số trên phần mềm terminal để truy cập vào switch

Sau khi nhấn Open, các bạn sẽ truy cập được vào CLI của switch. Các bạn chờ switch khởi động xong và đăng nhập với tài khoản mặc định là cisco/cisco.

đăng nhập với tài khoản mặc định là cisco/cisco

Ở lần đầu đăng nhập, switch sẽ yêu cầu các bạn thay đổi tài khoản và mật khẩu mặc định, các bạn nhập username và password mới vào. Tuy nhiên mật khẩu cần phải tuân thủ 7 quy tắc của Cisco ở phía trên. Nếu các bạn nhận thông báo Password Rejected, nghĩa là mật khẩu của các bạn chưa đáp ứng được quy tắc. Còn nếu switch thông báo Username and password were successfully updated là các bạn đã thay đổi tài khoản thành công. Khi đó các bạn có thể cấu hình switch trên giao diện CLI.

thay đổi tài khoản và mật khẩu mặc định

Thay đổi hostname và phân quyền tài khoản

Để thay đổi hostname cho switch, các bạn vào mode configure và nhập lệnh hostname NEW-HOSTNAME.

switch# configure
switch(config)# hostname SW-ACC-CNTTSHOP
SW-ACC-CNTTSHOP(config)#

Để tạo thêm tài khoản và phân quyền cho các tài khoản, các bạn vào mode configure, tạo tài khoản bằng lệnh username NEW-USERNAME password NEWPASSWORD privilege PRI-LEVEL.

Switch# configure
Switch(config)# username cnttshop password Admin@123 privilege 15

Trong đó privilege là tham số để phân quyền cho người dùng, có 3 mức level mà các bạn có thể cấu hình:

  • Privilege level 1 (Read-Only CLI Access): User ở mức level 1 không thể truy cập vào giao diện web, và chỉ có thể sử dụng các câu lệnh show, không thay đổi đến cấu hình của switch. Level này áp dụng cho những người dùng chỉ monitor hệ thống.
  • Privilege level 7 (Read/Limited Write CLI Access): User không truy cập được giao diện web, và chỉ có thể sử dụng các câu lệnh show, và 1 số câu lệnh cơ bản làm thay đổi cấu hình hệ thống.
  • Privilege level 15 (Read/Write Management Access): mức level cao nhất, user có thể thực thi mọi câu lệnh hỗ trợ trên switch.

Tắt tính năng Smartport

Trên tất cả các dòng switch SMB của Cisco như các dòng CBS hay C1200, 1300 series đều hỗ trợ tính năng Smartport, cho phép switch xác định thiết bị kết nối vào switch thuộc loại nào dựa trên macro được cấu hình sẵn, nên switch sẽ tự động cấu hình các port thành access hoặc trunking. Việc cấu hình tự động có thể khiến cấu hình không theo mong muốn, nếu các bạn không nắm rõ được cách thức hoạt động của tính năng. Do vậy mình khuyến nghị các bạn nên tắt tính năng này đi và cấu hình theo đúng mô hình của mình, vì các tính năng access hoặc trunking cấu hình khá nhanh và đơn giản.

Để tắt tính năng này, các bạn vào mode configure và nhập lệnh macro auto disabled.

switch# configure
switch(config)# macro auto disabled

Cấu hình VLAN, Access và trunking ports

Để tạo VLAN, các bạn vào mode configure, tạo VLAN bằng lênh vlan VLAN-ID. Trong ví dụ bên dưới mình tạo VLAN 20, với tên là CAMERA và VLAN 30 với tên là DATA.

switch# configure
switch(config)#vlan 20
switch(config-if)#name CAMERA
switch(config)#vlan 30
switch(config-if)#name DATA

Để gán các cổng vào VLAN cụ thể, các bạn chuyển cổng đó sang mode access và access vào VLAN tương ứng. Ví dụ bên dưới mình sẽ gán cổng 10 vào vlan 20, và cổng từ 11 đến 20 vào VLAN 30 (trường hợp này mình sử dụng interface range để cấu hình nhiều cổng cùng lúc).

switch# configure
switch(config)#interface g1/0/10
switch(config-if)#switchport mode access
switch(config-if)#switchport access vlan 20
switch(config)#exit
switch(config)# interface range gi1/0/11-20
switch(config-if-range)#switchport mode access
switch(config-if-range)#switchport access vlan 30

Các cổng nối giữa các switch thì thường chúng ta sẽ cấu hình như các cổng Trunk và chỉ allowed các VLAN có trên switch. Các bạn chuyển cổng sang mode trunk và sử dụng lệnh switchport trunk allowed vlan xxx để cho phép các VLAN trên đường trunk này. Như ví dụ bên dưới mình cấu hình cổng 25 và 26 như các cổng trunk và chỉ cho phép 3 VLAN 1, 20, 30 trên cổng trunk này.

Ngoài ra các bạn có thể đổi VLAN default trên cổng trunk bằng lệnh switchport trunk native vlan xxx. VLAN nào được native sẽ không tag VLAN ID khi đi qua cổng trunk này, mặc định sẽ là VLAN 1.

switch# configure
switch(config)# interface range gi1/0/25-26
switch(config-if-range)# switchport mode trunk
switch(config-if-range)# switchport trunk allowed vlan 1, 20, 30
switch(config-if-range)# switchport trunk native vlan 1

Cấu hình IP và Route cho switch

Nếu các bạn chỉ sử dụng switch như các switch Access, chúng ta có thể đặt IP trên 1 VLAN cụ thể để truy cập vào switch qua giao diện web, TELNET hoặc SSH. Còn nếu switch layer 3 và các bạn đặt Gateway trên switch này, thì chúng ta sẽ cấu hình mỗi VLAN 1 địa chỉ IP, và IP này sẽ là IP gateway cho mạng LAN.

Để cấu hình IP, các bạn vào interface vlan tương ứng và đặt IP bằng lệnh ip address 172.16.0.10 255.255.255.0.

switch# configure
switch(config)# interface vlan 1
switch(config-if)#ip address 172.16.0.10 255.255.255.0

Các bạn sẽ cần cấu hình thêm static route hoặc default route tùy vào từng mô hình. Ví dụ mình muốn quản trị switch từ VLAN khác qua IP thuộc VLAN 1, hoặc Gateway các bạn đặt trên switch này, thì các bạn sẽ cần cấu hình default route trỏ tới IP next-hop. Như trường hợp của mình là default route trỏ đến IP Gateway của VLAN 1 (dải 172.16.0.0/24) để mình có thể truy cập từ VLAN khác.

switch (config) # ip route 0.0.0.0 0.0.0.0 172.16.0.1

Bật Telnet và SSH

Khi các bạn quen sử dụng giao diện dòng lệnh CLI, chúng ta nên bật Telnet và SSH để có thể truy cập vào switch từ xa.

Để bật Telnet, các bạn sử dụng lệnh ip telnet server trong mode configure.

switch(config)# ip telnet server

Để bật SSH, các bạn sử dụng lệnh ip ssh server trong mode configure. Switch sẽ tự động sinh ra các khóa crypto, nếu các bạn muốn tạo khóa mới thì có thể sử dụng lệnh crypto key generate dsa hoặc crypto key generate rsa tùy theo phương thức mã hóa mà các bạn chọn.

switch(config)# ip ssh server
switch(config)# crypto key generate rsa

Lưu cấu hình

Sau khi cấu hình xong toàn bộ tính năng, các bạn sẽ cần lưu lại cấu hình cho switch. Sử dụng lệnh write memory trong mode EXEC, chọn Y để lưu.

switch# write memory
Overwrite file [startup-config].... (Y/N) [N] ? Y

Kết luận

Như vậy là mình đã hướng dẫn các bạn cấu hình 1 số tính năng cơ bản mà chúng ta cần phải cấu hình khi triển khai 1 switch mới như tạo và phân quyền tài khoản, cấu hình VLAN, cấu hình access port và trunking... Nếu các bạn có thắc mắc hay góp ý, hãy để lại comment để mọi người cùng trao đổi nhé.

Chúc các bạn thành công!

Lê Văn Tuấn

Là chuyên gia trong lĩnh vực Network System, Security, Server.. Có kinh nghiệm nhiều năm tư vấn giải pháp mạng, triển khai các giải pháp CNTT và phân phối thiết bị mạng Switch, Wifi, Router, Máy chủ Server, Lưu trữ Storage, Tường lửa Firewall, Video Conferencing, Module quang, Load Balancing. Hiện tại tôi là Founder và Managing Director công ty TNHH Công Nghệ Việt Thái Dương (CNTTShop.vn).

Bình luận bài viết!

Có 0 bình luận:
Chuyên mục chính
Bài viết cùng danh mục
Sản phẩm liên quan