CÔNG TY TNHH CÔNG NGHỆ VIỆT THÁI DƯƠNG
Logo CNTTShop.vn

NTT03, Line 1, Thống Nhất Complex, Thanh Xuân, Hà Nội.
Danh mục sản phẩm

Configure IPv6 BGP Route Reflector

Network Requirements

  • Set up EBGP neighbors between Device3 and Device4, and configure Device4 to advertise route 2001:4::/64.
  • Set up IBGP neighbors between Device2 and Device3 and between Device2 and Device1 respectively. On Device2, configure Route Reflectors (RRs), and configure Device1 and Device3 as clients, so that Device1 can learn route 2001:4::/64 that is advertised by Device4.

Network Topology

Networking for configuring an IPv6 BGP route reflector

Figure 13–4 Networking for configuring an IPv6 BGP route reflector

Configuration Steps

Step 1: Configure the IPv6 global unicast addresses of the interfaces. (Omitted)

Step 2: Configure OSPFv3 so that loopback routes are reachable between devices.

#Configure Device1.

Device1#configure terminal
Device1(config)#ipv6 router ospf 100
Device1(config-ospf6)#router-id 1.1.1.1
Device1(config-ospf6)#exit
Device1(config)#interface vlan 2
Device1(config-if-vlan2)#ipv6 router ospf 100 area 0
Device1(config-if-vlan2)#exit
Device1(config)#interface loopback 0
Device1(config-if-loopback0)#ipv6 router ospf 100 area 0
Device1(config-if-loopback0)#exit

#Configure Device2.

Device2#configure terminal
Device2(config)#ipv6 router ospf 100
Device2(config-ospf6)#router-id 2.2.2.2
Device2(config-ospf6)#exit
Device2(config)#interface vlan 2
Device2(config-if-vlan2)#ipv6 router ospf 100 area 0
Device2(config-if-vlan2)#exit
Device2(config)#interface vlan3
Device2(config-if-vlan3)#ipv6 router ospf 100 area 0
Device2(config-if-vlan3)#exit
Device2(config)#interface loopback 0
Device2(config-if-loopback0)#ipv6 router ospf 100 area 0
Device2(config-if-loopback0)#exit

#Configure Device3.

Device3#configure terminal
Device3(config)#ipv6 router ospf 100
Device3(config-ospf6)#router-id 3.3.3.3
Device3(config-ospf6)#exit
Device3(config)#interface vlan3
Device3(config-if-vlan3)#ipv6 router ospf 100 area 0
Device3(config-if-vlan3)#exit
Device3(config)#interface loopback 0
Device3(config-if-loopback0)#ipv6 router ospf 100 area 0
Device3(config-if-loopback0)#exit

#View the route table of Device1.

Device1#show ipv6 route 
Codes: C - Connected, L - Local, S - static, R - RIP, B - BGP, i-ISIS 
       U - Per-user Static route 
       O - OSPF, OE-OSPF External, M - Management 
 
L ::1/128 [0/0] 
     via ::, 1w2d:06:26:16, lo0
LC 1::1/128 [0/0] 
     via ::, 00:13:56, loopback0
O 2::2/128 [110/2] 
     via fe80::201:7aff:fec0:525a, 00:09:06, vlan2
O  3::3/128 [110/3] 
     via fe80::201:7aff:fec0:525a, 00:00:36, vlan2
C  2001:1::/64 [0/0] 
     via ::, 00:14:03, vlan2
L 2001:1::1/128 [0/0] 
     via ::, 00:14:02, lo0
O 2001:2::/64 [110/2] 
     via fe80::201:7aff:fec0:525a, 00:09:06, vlan2

#View the route table of Device2.

Device2#show ipv6 route 
Codes: C - Connected, L - Local, S - static, R - RIP, B - BGP, i-ISIS 
       U - Per-user Static route 
       O - OSPF, OE-OSPF External, M - Management 
 
L ::1/128 [0/0] 
     via ::, 1w6d:00:46:09, lo0
O 1::1/128 [110/2] 
     via fe80::201:7aff:fe5e:6d2e, 00:10:05, vlan2
LC 2::2/128 [0/0] 
     via ::, 00:14:23, loopback0
O 3::3/128 [110/2] 
     via fe80::201:7aff:fe62:bb80, 00:01:44, vlan3
C  2001:1::/64 [0/0] 
     via ::, 00:14:48, vlan2
L 2001:1::2/128 [0/0] 
     via ::, 00:14:47, lo0
C 2001:2::/64 [0/0] 
     via ::, 00:14:41, vlan3
L 2001:2::2/128 [0/0] 
     via ::, 00:14:39, lo0 

#View the route table of Device3.

Device3#show ipv6 route  
Codes: C - Connected, L - Local, S - static, R - RIP, B - BGP, i-ISIS 
       U - Per-user Static route 
       O - OSPF, OE-OSPF External, M - Management 
 
L ::1/128 [0/0] 
     via ::, 1w2d:06:37:24, lo0
O 1::1/128 [110/3] 
     via fe80::201:7aff:fec0:525b, 00:02:39, vlan3
O  2::2/128 [110/2] 
     via fe80::201:7aff:fec0:525b, 00:02:39, vlan3
LC 3::3/128 [0/0] 
     via ::, 00:14:45, loopback0
O 2001:1::/64 [110/2] 
     via fe80::201:7aff:fec0:525b, 00:02:39, vlan3
C  2001:2::/64 [0/0] 
     via ::, 00:15:03, vlan3
L 2001:2::1/128 [0/0] 
     via ::, 00:15:02, lo0
C 2001:3::/64 [0/0] 
     via ::, 00:14:55, vlan2
L 2001:3::1/128 [0/0] 
     via ::, 00:14:54, lo0 

According to the route table, Device1, Device2, and Device3 have learnt the routes of the loopback interfaces of each other.

Step 3: Configure the IPv6 BGP basic functions.

#Configure Device1.

Device1(config)#router bgp 100
Device1(config-bgp)#bgp router-id 1.1.1.1
Device1(config-bgp)#address-family ipv6
Device1(config-bgp-af)#neighbor 2::2 remote-as 100
Device1(config-bgp-af)#exit-address-family
Device1(config-bgp)#neighbor 2::2 update-source loopback 0
Device1(config-bgp)#exit

#Configure Device2.

Device2(config)#router bgp 100
Device2(config-bgp)#bgp router-id 2.2.2.2
Device2(config-bgp)#address-family ipv6
Device2(config-bgp-af)#neighbor 1::1 remote-as 100
Device2(config-bgp-af)#neighbor 3::3 remote-as 100
Device2(config-bgp-af)#exit-address-family
Device2(config-bgp)#neighbor 1::1 update-source loopback 0
Device2(config-bgp)#neighbor 3::3 update-source loopback 0
Device2(config-bgp)#exit

#Configure Device3.

Device3(config)#router bgp 100
Device3(config-bgp)#bgp router-id 3.3.3.3
Device3(config-bgp)#address-family ipv6
Device3(config-bgp-af)#neighbor 2::2 remote-as 100
Device3(config-bgp-af)#neighbor 2::2 next-hop-self
Device3(config-bgp-af)#neighbor 2001:3::2 remote-as 200
Device3(config-bgp-af)#exit-address-family
Device3(config-bgp)#neighbor 2::2 update-source loopback 0
Device3(config-bgp)#exit

#Configure Device4.

Device4#configure terminal
Device4(config)#router bgp 200
Device4(config-bgp)#bgp router-id 4.4.4.4
Device4(config-bgp)#address-family ipv6
Device4(config-bgp-af)#neighbor 2001:3::1 remote-as 100
Device4(config-bgp-af)#network 2001:4::/64
Device4(config-bgp-af)#exit-address-family
Device4(config-bgp)#exit

#On Device2, check the IPv6 BGP neighbor status.

Device2#show bgp ipv6 unicast summary  
BGP router identifier 2.2.2.2, local AS number 100 BGP table version is 2 
2 BGP AS-PATH entries 0 BGP community entries 
 
Neighbor    V AS        MsgRcvd MsgSent   TblVer InQ OutQ Up/Down State/PfxRcd
1::1           4 100      10         10             2        0     0      00:07:18       0 
3::3           4 100      10          9              2        0     0      00:06:53       1 
 
Total number of neighbors 2

#On Device4, check the IPv6 BGP neighbor status.

Device4#show bgp ipv6 unicast summary  
BGP router identifier 4.4.4.4, local AS number 200 BGP table version is 2 
1 BGP AS-PATH entries 0 BGP community entries 
 
Neighbor     V AS    MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2001:3::1   4 100   3            4           2        0     0      00:01:45       0 
 
Total number of neighbors 1 

According to the queried information, IPv6 BGP neighbors have been set up between the devices.

#Query the IPv6 BGP route table of Device3.

Device3#show bgp ipv6 unicast  
BGP table version is 3, local router ID is 3.3.3.3 
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              S Stale 
Origin codes: i - IGP, e - EGP, ? - incomplete 
          Network          Next Hop       Metric  LocPrf Weight Path
[B]*> 2001:4::/64     2001:3::2     0                   0         200 i

#View the IPv6 BGP route table of Device2.

Device2#show bgp ipv6 unicast  
BGP table version is 7, local router ID is 2.2.2.2 
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              S Stale 
Origin codes: i - IGP, e - EGP, ? - incomplete 
         Network           Next Hop    Metric  LocPrf Weight Path
[B]*> i2001:4::/64    3::3           0         100     0        200 i 

#Query the IPv6 BGP route table of Device1.

Device1#show bgp ipv6 unicast

According to the above result, Device2 and Device3 have learnt route 2001:4::/64, and Device2 has not advertised the route to Device1.

Step 4: Configure an IPv6 BGP route reflector.

#Configure Device2.

Device2(config)#router bgp 100
Device2(config-bgp)#address-family ipv6
Device2(config-bgp-af)#neighbor 1::1 route-reflector-client
Device2(config-bgp-af)#neighbor 3::3 route-reflector-client
Device2(config-bgp-af)#exit-address-family
Device2(config-bgp)#exit

On Device2, Device1 and Device3 have been configured as the RR clients.

Step 5: Check the result.

#View the route table of Device1.

Device1#show bgp ipv6 unicast  
BGP table version is 2, local router ID is 1.1.1.1 
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              S Stale 
Origin codes: i - IGP, e - EGP, ? - incomplete 

         Network            Next Hop  Metric  LocPrf Weight Path
[B]*> i2001:4::/64    3::3          0        100     0         200 i

Device1#show ipv6 route 
Codes: C - Connected, L - Local, S - static, R - RIP, B - BGP, i-ISIS 
       U - Per-user Static route 
       O - OSPF, OE-OSPF External, M - Management 
 
L ::1/128 [0/0] 
     via ::, 1w2d:06:48:52, lo0
LC 1::1/128 [0/0] 
     via ::, 00:36:32, loopback0
O 2::2/128 [110/2] 
     via fe80::201:7aff:fec0:525a, 00:31:42, vlan2
O  3::3/128 [110/3] 
     via fe80::201:7aff:fec0:525a, 00:23:12, vlan2
C  2001:1::/64 [0/0] 
     via ::, 00:36:39, vlan2
L 2001:1::1/128 [0/0] 
     via ::, 00:36:38, lo0
O 2001:2::/64 [110/2] 
     via fe80::201:7aff:fec0:525a, 00:31:42, vlan2
B  2001:4::/64 [200/0] 
     via 3::3, 00:01:16, vlan2 

On BGP of Device2, Device1 and Device3 have been configured as the RR clients, and Device2 has successfully reflects route 2001:4::/64 to RR client Device1.

note


  • If you configure an IPv6 BGP neighbor as a RR client, the neighbor will be reset.