Network Requirements
- Configure the redistribution to introduce the external routing to the IS-IS, enabling network interconnection between devices.
- Device1 and Device2 are the Level-2 routers. Configure the IS-IS and the Area 10. Configure the OSPF on Device2 and Device3. Redistribute the OSPF routing to the IS-IS through the configuration on Device2.
Network Topology
Figure 9–4 Networking of the IS-IS routing redistribution
Configuration Steps
Step 1: Configure the IP address of the interfaces. (Omitted)
Step 2: Configure the IS-IS and enable the process on the interface.
#Configure the IS-IS process as 100, area number as 10, and type as Level-2 and enable the process on the interface on Device1.
Device1#configure terminal
Device1(config)#router isis 100
Device1(config-isis)#net 10.0000.0000.0001.00
Device1(config-isis)#is-type level-2
Device1(config-isis)#metric-style wide
Device1(config-isis)#exit
Device1(config)#interface vlan2
Device1(config-if-vlan2)#ip router isis 100
Device1(config-if-vlan2)#exit
Device1(config)#interface vlan3
Device1(config-if-vlan3)#ip router isis 100
Device1(config-if-vlan3)#exit
|
#Configure the IS-IS process as 100, area number as 10, and type as Level-1-2 and enable the process on the interface on Device2.
Device2#configure terminal
Device2(config)#router isis 100
Device2(config-isis)#net 10.0000.0000.0002.00
Device2(config-isis)#is-type level-2
Device2(config-isis)#metric-style wide
Device2(config-isis)#exit
Device2(config)#interface vlan3
Device2(config-if-vlan3)#ip router isis 100
Device2(config-if-vlan3)#exit
|
Step 3: Configure the OSPF.
#Configure Device2.
Device2(config)#router ospf 100
Device2(config-ospf)#network 200.1.1.0 0.0.0.255 area 0
Device2(config-ospf)#exit
|
#Configure Device3.
Device3#configure terminal
Device3(config)#router ospf 100
Device3(config-ospf)#network 210.1.1.0 0.0.0.255 area 0
Device3(config-ospf)#network 200.1.1.0 0.0.0.255 area 0
Device3(config-ospf)#exit
|
#View the routing table of Device1. Device1 does not learn the OSPF routing redistributed by Device2.
Device1#show ip route
Codes: C - connected, S - static, R - RIP, O - OSPF, OE-OSPF External, M - Management
D - Redirect, E - IRMP, EX - IRMP external, o - SNSP, B - BGP, i-IS-IS
Gateway of last resort is not set
C 10.1.1.0/24 is directly connected, 00:58:39, vlan2
C 100.1.1.0/24 is directly connected, 06:55:35, vlan3
C 127.0.0.0/8 is directly connected, 603:06:22, lo0
Device1#show isis ipv4 route
IS-IS Instance 100, VRF Kernel, IPv4 routes table (Counter 2):
L2 10.1.1.0/24, flags none, metric 10, from network connected
via 0.0.0.0, vlan2
L2 100.1.1.0/24, flags none, metric 10, from network connected
via 0.0.0.0, vlan3
Device1#show isis database detail
IS-IS Instance 100 Level-2 Link State Database (Counter 3, LSP-MTU 1492):
LSPID LSP Seq Num LSP Checksum LSP Holdtime Length ATT/P/OL
0000.0000.0001.00-00* 0x00000046 0x489E 1123 71 0/0/0
NLPID: IPv4
Area Address: 10
IP Address: 100.1.1.1
Metric: 10 IS-Extended 0000.0000.0001.01
Metric: 10 IP-Extended 10.1.1.0/24
Metric: 10 IP-Extended 100.1.1.0/24
0000.0000.0001.01-00* 0x00000045 0x097D 1103 51 0/0/0
Metric: 0 IS-Extended 0000.0000.0001.00
Metric: 0 IS-Extended 0000.0000.0002.00
0000.0000.0002.00-00 0x000000CB 0xEEA6 679 63 0/0/0
NLPID: IPv4
Area Address: 10
IP Address 100.1.1.2
Metric: 10 IS-Extended 0000.0000.0001.01
Metric: 10 IP-Extended 100.1.1.0/24
#View the routing table of Device2. Device2 learns the IS-IS and OSPF routing.
Device2#show ip route
Codes: C - connected, S - static, R - RIP, O - OSPF, OE-OSPF External, M Management
D - Redirect, E - IRMP, EX - IRMP external, o - SNSP, B BGP, i-IS-IS
Gateway of last resort is not set
i 10.1.1.0/24 [115/20] via 100.1.1.1, 15:45:37, vlan3
C 100.1.1.0/24 is directly connected, 22:38:58, vlan3
C 127.0.0.0/8 is directly connected, 300:03:03, lo0
C 200.1.1.0/24 is directly connected, 22:38:58, vlan2
O 210.1.1.1/32 [110/2] via 200.1.1.2, 15:43:35, vlan2
Device2#show isis ipv4 route
IS-IS Instance 100, VRF Kernel, IPv4 routes table (Counter 2):
L2 10.1.1.0/24, flags none, metric 20, from learned, installed
via 100.1.1.1, vlan3, neighbor 0000.0000.0001
L2 100.1.1.0/24, flags none, metric 10, from network connected
via 0.0.0.0, vlan3
Device2#show isis database detail
IS-IS Instance 100 Level-2 Link State Database (Counter 3, LSP-MTU 1492):
LSPID LSP Seq Num LSP Checksum LSP Holdtime Length ATT/P/OL
0000.0000.0001.00-00 0x00000046 0x489E 911 71 0/0/0
NLPID: IPv4
Area Address: 10
IP Address: 100.1.1.1
Metric: 10 IS-Extended 0000.0000.0001.01
Metric: 10 IP-Extended 10.1.1.0/24
Metric: 10 IP-Extended 100.1.1.0/24
0000.0000.0001.01-00 0x00000045 0x097D 892 51 0/0/0
Metric: 0 IS-Extended 0000.0000.0001.00
Metric: 0 IS-Extended 0000.0000.0002.00
0000.0000.0002.00-00* 0x000000CB 0xEEA6 467 63 0/0/0
NLPID: IPv4
Area Address: 10
IP Address: 100.1.1.2
Metric: 10 IS-Extended 0000.0000.0001.01
Metric: 10 IP-Extended 100.1.1.0/24
Step 4: Configure the IS-IS to redistribute the OSPF routing.
#Configure the OSPF routing to be redistributed to IS-IS Level-2 on Device2.
Device2(config)#router isis 100
Device2(config-isis)#address-family ipv4 unicast
Device2(config-isis-af)#redistribute ospf 100 level-2
Device2(config-isis-af)#exit Device2(config-isis)#exit
|
Step 5: Check the result.
#View the routing information of Device1. Device1 leans the OSPF routing redistributed by Device2.
Device1#show ip route
Codes: C - connected, S - static, R - RIP, O - OSPF, OE-OSPF External, M - Management
D - Redirect, E - IRMP, EX - IRMP external, o - SNSP, B - BGP, i-IS-IS
Gateway of last resort is not set
C 10.1.1.0/24 is directly connected, 16:47:30, vlan2
C 100.1.1.0/24 is directly connected, 22:44:27, vlan3
C 127.0.0.0/8 is directly connected, 618:55:13, lo0
i 200.1.1.0/24 [115/10] via 100.1.1.2, 00:00:05, vlan3
i 210.1.1.1/32 [115/10] via 100.1.1.2, 00:00:05, vlan3
Device1#show isis ipv4 route
IS-IS Instance 100, VRF Kernel, IPv4 routes table (Counter 4):
L2 10.1.1.0/24, flags none, metric 10, from network connected
via 0.0.0.0, vlan2
L2 100.1.1.0/24, flags none, metric 10, from network connected
via 0.0.0.0, vlan3
L2 200.1.1.0/24, flags none, metric 10, from learned, installed
via 100.1.1.2, vlan3, neighbor 0000.0000.0002
L2 210.1.1.1/32, flags none, metric 10, from learned, installed
via 100.1.1.2, vlan3, neighbor 0000.0000.0002
Device1#show isis database detail
IS-IS Instance 100 Level-2 Link State Database (Counter 3, LSP-MTU 1492):
LSPID LSP Seq Num LSP Checksum LSP Holdtime Length ATT/P/OL
0000.0000.0001.00-00* 0x00000046 0x489E 626 71 0/0/0
NLPID: IPv4
Area Address: 10
IP Address: 100.1.1.1
Metric: 10 IS-Extended 0000.0000.0001.01
Metric: 10 IP-Extended 10.1.1.0/24
Metric: 10 IP-Extended 100.1.1.0/24
0000.0000.0001.01-00* 0x00000045 0x097D 606 51 0/0/0
Metric: 0 IS-Extended 0000.0000.0001.00
Metric: 0 IS-Extended 0000.0000.0002.00
0000.0000.0002.00-00 0x000000CD 0xC6E2 1184 80 0/0/0
NLPID: IPv4
Area Address: 10
IP Address: 100.1.1.2
Metric: 10 IS-Extended 0000.0000.0001.01
Metric: 10 IP-Extended 100.1.1.0/24
Metric: 0 IP-Extended 200.1.1.0/24
Metric: 0 IP-Extended 210.1.1.1/32
Device1 learns the redistributed OSPF routing.