Network Requirements
- The whole network enables the PIM-DM protocol.
- Receiver is one receiver of the Device2 end network.
- Run IGMPv2 between Device2 and the end network.
Network Topology
Figure 6-1 Networking of configuring the PIM-DM basic functions
Configuration Steps
Step 1: Configure VLAN and add the port to the corresponding VLAN. (omitted)
Step 2: Configure the IP address of the interface. (omitted)
Step 3: Enable the unicast route protocol OSPF so that all devices in the network can communicate with each other.
#Configure Device1.
Device1#configure terminal
Device1(config)#router ospf 100
Device1(config-ospf)#network 1.0.0.0 0.0.0.255 area 0
Device1(config-ospf)#network 192.168.1.0 0.0.0.255 area 0
Device1(config-ospf)#exit
|
#Configure Device2.
Device2#configure terminal
Device2(config)#router ospf 100
Device2(config-ospf)#network 1.0.0.0 0.0.0.255 area 0
Device2(config-ospf)#exit
|
#View the route table of Device2.
Device2#show ip route
Codes: C - connected, S - static, R - RIP, O - OSPF, OE-OSPF External, M - Management
D - Redirect, E - IRMP, Ex - IRMP external, o - SNSP, B - BGP, i-ISIS
Gateway of last resort is not set
C 1.0.0.0/24 is directly connected, 00:07:30, vlan3
C 2.0.0.0/24 is directly connected, 00:07:14, vlan4
O 192.168.1.0/24 [110/2] via 1.0.0.1, 00:00:16, vlan3
-
The method of viewing the route table of Device1 is the same as that of Device2.
Step 4: Globally enable the multicast forwarding and enable the multicast protocol PIM-DM on the interface.
#Configure Device1.
Globally enable the multicast forwarding and enable the multicast protocol PIM-DM on the interface.
Device1(config)#ip multicast-routing
Device1(config)#interface vlan 2
Device1(config-if-vlan2)#ip pim dense-mode
Device1(config-if-vlan2)#exit
Device1(config)#interface vlan 3
Device1(config-if-vlan3)#ip pim dense-mode
Device1(config-if-vlan3)#exit
|
#Configure Device2.
Globally enable the multicast forwarding and enable the multicast protocol PIM-DM on the interface.
Device2(config)#ip multicast-routing
Device2(config)#interface vlan 3
Device2(config-if-vlan3)#ip pim dense-mode
Device2(config-if-vlan3)#exit
Device2(config)#interface vlan 4
Device2(config-if-vlan4)#ip pim dense-mode
Device2(config-if-vlan4)#exit
|
#View the information of the interface enabled with the PIM-DM protocol on Device2 and the PIM-DM neighbor information.
#View the IGMP information of interface VLAN4 of Device2.
Device2#show ip igmp interface vlan 4
Interface vlan4 (Index 65547)
IGMP Active, Querier (2.0.0.1)
Default version 2
IP router alert option in IGMP V2 msgs: EXCLUDE
Internet address is 2.0.0.1
IGMP query interval is 125 seconds
IGMP querier timeout is 255 seconds
IGMP max query response time is 10 seconds
Last member query response interval is 1 seconds
Last member query count is 2
Group Membership interval is 260 seconds
IGMP robustness variable is 2
-
The method of viewing the Device1 information is the same as that of Device2.
- After configuring the multicast protocol on the interface, automatically enable the IGMP function and run IGMPv2 by default. You can configure the running IGMP version on the interface by executing the ip igmp version command.
Step5: Check the result.
#Receiver sends the IGMPv2 member relation report to add to multicast group 225.1.1.1.
#Source sends the multicast packets with multicast group 225.1.1.1.
#View the multicast member table of Device2.
Device2#show ip igmp groups
IGMP Connected Group Membership Total 1 groups
Group Address Interface Uptime Expires Last Reporter V1 Expires V2 Expires
------------------------------------------------------------------------------------
225.1.1.1 vlan4 00:06:01 00:04:06 2.0.0.2 stopped
#View the PIM-DM multicast route table of Device2.
Device2#show ip pim dense-mode mroute
PIM-DM Multicast Routing Table
Total 1 mroute entries
(192.168.1.1, 225.1.1.1)
Expire in: 00:02:35
RPF Neighbor: 1.0.0.1, Nexthop: 1.0.0.1, vlan3
Upstream IF: vlan3
Upstream State: Forwarding
Assert State: Loser
Downstream IF List:
vlan4, in 'olist':
Downstream State: NoInfo
Assert State: NoInfo
#Receiver can receive the multicast packets with the multicast group 225.1.1.1 sent by Source.
-
The method of viewing the Device1 information is the same as that of Device2.