Network Requirements
- The whole network runs the PIM-SSM protocol.
- Receiver is one receiver of Device3 end network.
- Run IGMPv3 between Device3 and the end network.
Network Topology
Figure 7-2 Networking of configuring PIM-SSM
Configuration Steps
Step 1: Configure the IP address of the interface. (omitted)
Step 2: Enable the unicast route protocol OSPF so that all devices in the network can communicate with each other.
#Configure Device1.
Device1#configure terminal
Device1(config)#router ospf 100
Device1(config-ospf)#network 2.0.0.0 0.0.0.255 area 0
Device1(config-ospf)#network 3.0.0.0 0.0.0.255 area 0
Device1(config-ospf)#network 192.168.1.0 0.0.0.255 area 0
Device1(config-ospf)#exit
|
#Configure Device2.
Device2#configure terminal
Device2(config)#router ospf 100
Device2(config-ospf)#network 3.0.0.0 0.0.0.255 area 0
Device2(config-ospf)#network 4.0.0.0 0.0.0.255 area 0
Device2(config-ospf)#exit
|
#Configure Device3.
Device3#configure terminal
Device3(config)#router ospf 100
Device3(config-ospf)#network 2.0.0.0 0.0.0.255 area 0
Device3(config-ospf)#network 4.0.0.0 0.0.0.255 area 0
Device3(config-ospf)#exit
|
#View the route table of Device3.
Device3#show ip route
Codes: C - connected, S - static, R - RIP, O - OSPF, OE-OSPF External, M - Management
D - Redirect, E - IRMP, EX - IRMP external, o - SNSP, B - BGP, i-ISIS
Gateway of last resort is not set
C 2.0.0.0/24 is directly connected, 14:48:47, vlan3
O 3.0.0.0/24 [110/2] via 2.0.0.1, 14:31:14, vlan3
[110/2] via 4.0.0.1, 14:31:04, vlan6
C 4.0.0.0/24 is directly connected, 15:36:57, vlan6
C 5.0.0.0/24 is directly connected, 14:09:18, vlan5
O 192.168.1.0/24 [110/2] via 2.0.0.1, 00:30:55, vlan3
-
The viewing method of Device1 and device2 is the same as that of Device3, so the viewing process is omitted.
Step 3: Globally enable the multicast forwarding and enable the multicast protocol PIM-SM on the interface.
#Configure Device1.
Globally enable the multicast forwarding and enable the multicast protocol PIM-SM on the related interfaces.
Device1(config)#ip multicast-routing
Device1(config)#interface vlan2
Device1(config-if-vlan2)#ip pim sparse-mode
Device1(config-if-vlan2)#exit
Device1(config)#interface vlan3
Device1(config-if-vlan3)#ip pim sparse-mode
Device1(config-if-vlan3)#exit
Device1(config)#interface vlan4
Device1(config-if-vlan4)#ip pim sparse-mode
Device1(config-if-vlan4)#exit
|
#Configure Device2.
Globally enable the multicast forwarding and enable the multicast protocol PIM-SM on the related interfaces.
Device2(config)#ip multicast-routing
Device2(config)#interface vlan4
Device2(config-if-vlan4)#ip pim sparse-mode
Device2(config-if-vlan4)#exit
Device2(config)#interface vlan6
Device2(config-if-vlan6)#ip pim sparse-mode
Device2(config-if-vlan6)#exit
|
#Configure Device3.
Globally enable the multicast forwarding and enable the multicast protocol PIM-SM on the related interfaces.
Device3(config)#ip multicast-routing
Device3(config)#interface vlan3
Device3(config-if-vlan3)#ip pim sparse-mode
Device3(config-if-vlan3)#exit
Device3(config)#interface vlan5
Device3(config-if-vlan5)#ip pim sparse-mode
Device3(config-if-vlan5)#exit
Device3(config)#interface vlan6
Device3(config-if-vlan6)#ip pim sparse-mode
Device3(config-if-vlan6)#exit
|
#View the information of the interface enabled with the PIM-SM protocol on Device3 and the PIM-SM neighbor information.
Device3#show ip pim interface PIM Interface Table:
PIM VRF Name: Default Total 3 Interface entries
Total 0 External Interface entry
Total 0 Sparse-Dense Mode Interface entry
Address Interface VIF Ver/ VIF Nbr DR DR
BSR CISCO Neighbor
Index Mode Flag Count Pri
Border Neighbor Filter
2.0.0.2 vlan3 3 v2/S UP 1 1
2.0.0.2 FALSE FALSE
5.0.0.1 vlan5 0 v2/S UP 0 1
5.0.0.1 FALSE FALSE
4.0.0.2 vlan6 2 v2/S UP 1 1
4.0.0.2 FALSE FALSE
Device3#show ip pim neighbor PIM Neighbor Table:
PIM VRF Name: Default Total 2 Neighbor entries
Neighbor Interface Uptime/Expires Ver DR Priority/Mode
Address
2.0.0.1 vlan3 01:12:00/00:01:39 v2 1 /
4.0.0.1 vlan6 01:13:19/00:01:35 v2 1 /
-
The viewing method of Device1 and device2 is the same as that of Device3, so the viewing process is omitted.
Step 4: Configure PIM-SSM on all devices; the multicast group range of the SSM service is 232.0.0.0/8. vlan5 of Device3 runs IGMPv3.
#Configure Device1.
Device1(config)#ip pim ssm default
|
#Configure Device2.
Device2(config)#ip pim ssm default
|
#Configure Device3.
Device3(config)#ip pim ssm default
Device3(config)#interface vlan5
Device3(config-if-vlan5)#ip igmp version 3
Device3(config-if-vlan5)#exit
|
#View the IGMP information of interface VLAN5 of Device3.
Device3#show ip igmp interface vlan5
Interface vlan5 (Index 50332250)
IGMP Enabled, Active, Querier (5.0.0.1)
Configured for version 3
IP router alert option in IGMP V2 msgs: EXCLUDE
Internet address is 5.0.0.1
IGMP query interval is 125 seconds
IGMP querier timeout is 255 seconds
IGMP max query response time is 10 seconds
Last member query response interval is 1 seconds
Last member query count is 2
Group Membership interval is 260 seconds
IGMP robustness variable is 2
Step 5: Check the result.
#Receiver sends the IMGPv3 member relation report of the specified source group to add to multicast group 232.1.1.1; the specified multicast source is 192.168.1.1
#Source sends the multicast packets with multicast group 232.1.1.1.
#View the multicast member table of Device3.
Device3#show ip igmp groups
IGMP Connected Group Membership Total 1 groups
Group Address Interface Uptime Expires Last Reporter V1 Expires V2 Expires
232.1.1.1 vlan5 00:11:14 stopped 5.0.0.2 stopped stopped
Device3#show ip igmp groups detail
Interface: vlan5
Group 232.1.1.1
Uptime: 00:11:20
Group mode: Include
Last reporter: 5.0.0.2
TIB-A Count: 1
TIB-B Count: 0
Group source list: (R - Remote, M SSM Mapping)
Source Address Uptime v3 Exp M Exp Fwd Flags
192.168.1.1 00:11:20 00:03:28 stopped Yes R
#View the multicast route table of Device3.
Device3#show ip pim mroute
IP Multicast Routing Table:
PIM VRF Name: Default
Total 0 (*,*,RP) entry
Total 0 (*,G) entry
Total 1 (S,G) entry
Total 0 (S,G,rpt) entry
Total 0 FCR entry
Up timer/Expiry timer
(192.168.1.1, 232.1.1.1)
Up time: 12:59:27
KAT time: 00:03:20
RPF nbr: 2.0.0.1
RPF idx: vlan3
SPT bit: TRUE
Flags:
JOIN DESIRED
Upstream State: JOINED
Local interface list:
Vlan5
Joined interface list:
Asserted interface list:
Outgoing interface list:
Vlan5
Packet count 109783214
#Receiver can only receive the multicast service packet with multicast group 232.1.1.1 sent by Source.
-
The viewing method of Device1 and device2 is the same as that of Device3, so the viewing process is omitted.
- The default multicast group range of PIM-SSM is 232.0.0.0/8. You can modify the multicast group range of the 232.0.0.0/8 service via the command ip pim ssm range.
- For the multicast group G meeting the SSM condition, the multicast route table does not generate the (*,G) entry, but just generate the (S,G) entry.