Network Requirements
- Device2 configures multicast routing protocol.
- Device1 enables IGMP snooping, unknown multicast dropping, and unknown multicast re-direction.
- Multicast Server sends the multicast service packet; PC1 can correctly receive the multicast service packet.
Network Topology
Figure 2-4 Network topology of configuring unknown multicast re-direction
Configuration Steps
Step 1: Configure the IP address of Device2 interface. (omitted)
Step 2: Enable PIM-SM on the interfaces of Device2, and enable IGMP snooping and unknown multicast re-direction on Device1.
#On Device2, configure the link type of port gigabitethernet0/2 as Access, permitting VLAN3 services to pass, configure the link type of port gigabitethernet0/1 as trunk, permitting VLAN2 service to pass, and configure PVID as 1.
Device2(config)#vlan2-3
Device2(config)#interface gigabitethernet 0/2
Device2(config-if-gigabitethernet0/2)#switchport access vlan 3
Device2(config-if-gigabitethernet0/2)#exit
Device2(config)#interface gigabitethernet 0/1
Device2(config-if-gigabitethernet0/1)#switchport mode trunk
Device2(config-if-gigabitethernet0/1)#switchport trunk allowed vlan add 2
Device2(config-if-gigabitethernet0/1)#switchport trunk pvid vlan 1
Device2(config-if-gigabitethernet0/1)#exit
|
#Globally enable multicast forwarding on Device2, and enable PIM-SM on the related interfaces.
Device2(config)#ip multicast-routing
Device2(config)#interface vlan2
Device2(config-if-vlan2)#ip pim sparse-mode
Device2(config-if-vlan2)#exit
Device2(config)#interface vlan3
Device2(config-if-vlan2)#ip pim sparse-mode
Device2(config-if-vlan3)#exit
|
#On Device1, configure the link type of port gigabitethernet0/2 as Access, permitting VLAN2 services to pass, configure the link type of port gigabitethernet0/1 as trunk, permitting VLAN2 service to pass, and configure PVID as 1.
Device1(config)#interface gigabitethernet 0/2
Device1(config-if-gigabitethernet0/2)# switchport access vlan 2
Device1(config-if-gigabitethernet0/2)#exit
Device1(config)#interface gigabitethernet 0/1
Device1(config-if-gigabitethernet0/1)#switchport mode trunk
Device1(config-if-gigabitethernet0/1)#switchport trunk allowed vlan add 2
Device1(config-if-gigabitethernet0/1)#switchport trunk pvid vlan 1
Device1(config-if-gigabitethernet0/1)#exit
|
#In VLAN2, enable unknown multicast dropping.
Device1(config)#vlan 2
Device1(config-vlan2)#l2-multicast drop-unknown
Device1(config-vlan2)#l3-multicast drop-unknown
Device1(config-vlan2)#exit
|
#Enable IGMP snooping.
Device1(config)#ip igmp snooping
Device1(config)#ip igmp snooping vlan 2
|
#In VLAN2, enable unknown multicast re-direction.
Device1(config)#vlan 2
Device1(config-vlan2)#multicast mrouter-forwarding
Device1(config-vlan2)#exit
|
Step 3: Check the result.
#View the IGMP snooping router ports (uplink ports) learned on Device1.
Device1#show ip igmp snooping mrouter
Vlan SourceAddr Expires Interface
---- ---------- ------- ---------
2 192.168.1.1 00:04:04 gigabitethernet0/1(dynamic)
#PC1 sends IGMPv2 member report packets to join multicast group 224.1.1.1.
#Query the multicast member table of Device2.
Device2#show ip igmp groups
IGMP Connected Group Membership
Total 1 groups
Group Address Interface Uptime Expires Last Reporter V1 Expires V2 Expires
-----------------------------------------------------------------------------------
224.1.1.1 vlan3 00:21:02 00:03:47 192.168.1.2 stopped
#Multicast server sends the multicast service packet whose destination address is 224.1.1.1. PC1. View the multicast route table entries on Device2.
Device2#show ip pim mroute
IP Multicast Routing Table:
PIM VRF Name: Default
Total 0 (*,*,RP) entry
Total 1 (*,G) entry
Total 1 (S,G) entry
Total 1 (S,G,rpt) entry
Total 0 FCR entry
Up timer/Expiry timer
(*, 224.1.1.1)
Up time: 00:08:12
RP: 0.0.0.0
RPF nbr: 0.0.0.0
RPF idx: None
Flags:
JOIN DESIRED
Upstream State: JOINED
Local interface list:
vlan3
Joined interface list:
Asserted interface list:
(192.168.1.100, 224.1.1.1)
Up time: 00:07:24
KAT time: 00:02:22
RPF nbr: 0.0.0.0
RPF idx: None
SPT bit: TRUE
Flags:
JOIN DESIRED
COULD REGISTER
Upstream State: JOINED
Local interface list:
Joined interface list:
register_vif0
Asserted interface list:
Outgoing interface list:
register_vif0
vlan3
Packet count 8646421
(192.168.1.100, 224.1.1.1, rpt)
Up time: 00:07:24
RP: 0.0.0.0
Flags:
RPT JOIN DESIRED
RPF SGRPT XG EQUAL
Upstream State: NOT PRUNED
Local interface list:
Pruned interface list:
Outgoing interface list: vlan3
#PC1 can correctly receive the multicast service packets sent by Multicast Server.