Network Requirements
- The IRMP protocol operates among Device1, Device2, Device3, and Device4 for routing interaction,
- Device1 learns two routing 100.1.0.0/24 and 100.2.0.0/24 from Device. To reduce the routing table scale of Device1, it is required that Device2 only releases the route summary 100.0.0.0/14 to Device1.
Network Topology
Figure 11–5 Networking of the IRMP route summary
Configuration Steps
Step 1: Configure the IP address of the interfaces. (Omitted)
Step 2: Configure the IRMP.
#Configure Device1.
Device1#configure terminal
Device1(config)#router irmp 100
Device1(config-irmp)#network 1.0.0.0 0.0.0.255
Device1(config-irmp)#exit
|
#Configure Device2.
Device2#configure terminal
Device2(config)#router irmp 100
Device2(config-irmp)#network 1.0.0.0 0.0.0.255
Device2(config-irmp)#network 2.0.0.0 0.0.0.255
Device2(config-irmp)#network 3.0.0.0 0.0.0.255
Device2(config-irmp)#exit
|
#Configure Device3.
Device3#configure terminal
Device3(config)#router irmp 100
Device3(config-irmp)#network 2.0.0.0 0.0.0.255
Device3(config-irmp)#network 100.1.0.0 0.0.0.255
Device3(config-irmp)#exit
|
#Configure Device4.
Device4#configure terminal
Device4(config)#router irmp 100
Device4(config-irmp)#network 3.0.0.0 0.0.0.255
Device4(config-irmp)#network 100.2.0.0 0.0.0.255
Device4(config-irmp)#exit
|
#View the IRMP neighbor inofrmation of Device2.
Device2#show ip irmp neighbor
IP-IRMP neighbors for process 100 Total neighbor 3
Address Interface Hold(s) Uptime SeqNum Srtt(ms) Rto(s)
1.0.0.1 gigabitethernet0 11 00:05:04 4 0 2
2.0.0.2 gigabitethernet0 14 00:04:42 3 16 2
3.0.0.2 gigabitethernet0 11 00:04:00 2 0 2
Device2 successfully establishes the IRMP neighbor with Device1, Device3, and Device4, respectively.
#View the topology table and routing table of Device2.
Device2#show ip irmp topology
IP-IRMP Topology Table for process 100
Codes: P - Passive, A - Active, H - Holddown, D - Hidden
> - FIB route, * - FIB successor
P >1.0.0.0/24, 1 successors, FD is 2816
*via Connected (2816/0), gigabitethernet0
P >2.0.0.0/24, 1 successors, FD is 2816
*via Connected (2816/0), gigabitethernet1
P >3.0.0.0/24, 1 successors, FD is 2816
*via Connected (2816/0), gigabitethernet2
P >100.1.0.0/24, 1 successors, FD is 3072
*via 2.0.0.2 (3072/2816), gigabitethernet1
P >100.2.0.0/24, 1 successors, FD is 3072
*via 3.0.0.2 (3072/2816), gigabitethernet2
Device2#show ip route
Codes: C - connected, S - static, R - RIP, O - OSPF, OE-OSPF External, M - Management
D - Redirect, E - IRMP, EX - IRMP external, o - SNSP, B - BGP, i-ISIS
Gateway of last resort is not set
C 1.0.0.0/24 is directly connected, 08:12:36, gigabitethernet0
C 2.0.0.0/24 is directly connected, 00:36:51, gigabitethernet1
C 3.0.0.0/24 is directly connected, 00:12:06, gigabitethernet2
E 100.1.0.0/24 [90/3072] via 2.0.0.2, 00:10:03, gigabitethernet1
E 100.2.0.0/24 [90/3072] via 3.0.0.2, 00:00:08, gigabitethernet2
C 127.0.0.0/8 is directly connected, 57:38:13, lo0
#View the topology table and routing table of Device1.
Device1#show ip irmp topology
IP-IRMP Topology Table for process 100
Codes: P - Passive, A - Active, H - Holddown, D Hidden
> - FIB route, * FIB successor
P >1.0.0.0/24, 1 successors, FD is 2816
*via Connected (2816/0), gigabitethernet0
P >2.0.0.0/24, 1 successors, FD is 3072
*via 1.0.0.2 (3072/2816), gigabitethernet0
P >3.0.0.0/24, 1 successors, FD is 3072
*via 1.0.0.2 (3072/2816), gigabitethernet0
P >100.1.0.0/24, 1 successors, FD is 3328
*via 1.0.0.2 (3328/3072), gigabitethernet0
P >100.2.0.0/24, 1 successors, FD is 3328
*via 1.0.0.2 (3328/3072), gigabitethernet0
Device1#show ip route
Codes: C - connected, S - static, R - RIP, O - OSPF, OE-OSPF External, M Management
D - Redirect, E - IRMP, EX - IRMP external, o - SNSP, B BGP, i-ISIS
Gateway of last resort is not set
C 1.0.0.0/24 is directly connected, 08:09:15, gigabitethernet0
E 2.0.0.0/24 [90/3072] via 1.0.0.2, 00:13:19, gigabitethernet0
E 3.0.0.0/24 [90/3072] via 1.0.0.2, 00:13:17, gigabitethernet0
E 100.1.0.0/24 [90/3328] via 1.0.0.2, 00:12:53, gigabitethernet0
E 100.2.0.0/24 [90/3328] via 1.0.0.2, 00:02:57, gigabitethernet0
C 127.0.0.0/8 is directly connected, 08:17:36, lo0
Both Device1 and Device2 learn routing 100.1.0.0/24 and 100.2.0.0/24.
Step 3: Configure the IRMP route summary.
#Configure Device2 and configure the IRMP route summary 100.0.0.0/14 on the interface connected to Device1.
Device2(config)#interface gigabitethernet0
Device2(config-if-gigabitethernet0)#ip summary-address irmp 100 100.0.0.0 255.252.0.0
Device2(config-if-gigabitethernet0)#exit
|
Step 4: Check the result.
#View the IRMP topology table of Device2.
Device2#show ip irmp topology
IP-IRMP Topology Table for process 100
Codes: P - Passive, A - Active, H - Holddown, D - Hidden
> - FIB route, * - FIB successor
P >1.0.0.0/24, 1 successors, FD is 2816
*via Connected (2816/0), gigabitethernet0
P >2.0.0.0/24, 1 successors, FD is 2816
*via Connected (2816/0), gigabitethernet1
P >3.0.0.0/24, 1 successors, FD is 2816
*via Connected (2816/0), gigabitethernet2
P 100.0.0.0/14, 1 successors, FD is 3072
via AddrSumm (3072/0)
P >100.1.0.0/24, 1 successors, FD is 3072
*via 2.0.0.2 (3072/2816), gigabitethernet1
P >100.2.0.0/24, 1 successors, FD is 3072
*via 3.0.0.2 (3072/2816), gigabitethernet2
A route summary 100.0.0.0/14 is generated on Device2.
#View the topology table and routing table of Device1.
Device1#show ip irmp topology
IP-IRMP Topology Table for process 100
Codes: P - Passive, A - Active, H - Holddown, D - Hidden
> - FIB route, * - FIB successor
P >1.0.0.0/24, 1 successors, FD is 2816
*via Connected (2816/0), gigabitethernet0
P >2.0.0.0/24, 1 successors, FD is 3072
*via 1.0.0.2 (3072/2816), gigabitethernet0
P >3.0.0.0/24, 1 successors, FD is 3072
*via 1.0.0.2 (3072/2816), gigabitethernet0
P >100.0.0.0/14, 1 successors, FD is 3328
*via 1.0.0.2 (3328/3072), gigabitethernet0
Device1#show ip route
Codes: C - connected, S - static, R - RIP, O - OSPF, OE-OSPF External, M - Management
D - Redirect, E - IRMP, EX - IRMP external, o - SNSP, B - BGP, i-ISIS
Gateway of last resort is not set
C 1.0.0.0/24 is directly connected, 08:18:49, gigabitethernet0
E 2.0.0.0/24 [90/3072] via 1.0.0.2, 00:04:54, gigabitethernet0
E 3.0.0.0/24 [90/3072] via 1.0.0.2, 00:04:54, gigabitethernet0
E 100.0.0.0/14 [90/3328] via 1.0.0.2, 00:04:54, gigabitethernet0
C 127.0.0.0/8 is directly connected, 08:27:10, lo0
It can be viewed that only the route summary100.0.0.0/14 instead of the corresponding detailed route100.1.0.0/24 and 100.2.0.0/24 exists on Device1.
-
Configuring the IRMP route summary in the interface mode may cause the neighbor to be reestablished.